WordPress 5.0 更新筆記與心得建議

WordPress 在2018年底推出 5 系列的最新代更新版本,對使用者來說最大的首波改變就是先前已經推行一段時間的視覺化編輯系統「Gutenberg」,這次完整內建在 WordPress 核心內。

另外 WP 此次更新也順勢推出延續上一代 2017 年的全新佈景主題「Twenty Nineteen」,可和 Gutenberg 編輯器(WP 稱作區塊編輯器)完美搭配。

當然了,和過去每一代官方佈景主題一樣,拿來用可以,但是許多細部調控還是沒有第三方佈景主題來得好,對於進階網站主或是部落客來說可能稍微不夠。相信不久後其他第三方支援作者會參考該主題設計出更先進的主題。

我們已經在幾個網站上進行過版本更新,尚未出現異常狀態,相信大家也能安心安裝。

注意⚠️如果你的資料夾權限設置過於嚴苛(例如755),導致更新檔案無法順利取代舊檔案時,系統可能崩潰出現 500 的錯誤回應。這時候只要重新下載 WordPress 系統檔案,覆蓋舊檔案即可。

說起「Gutenberg」這套視覺化編輯系統相信有經常在維護 WP 系統的人應該都不太陌生,畢竟從半年前開始就開始一直被提醒要玩玩看!

Gutenberg

WordPress 5.0 版視覺化編輯器

Gutenberg 編輯器最大的優點是將每一段文字、每一張圖片與其他內容,都改採「Block」的區塊化編輯方式來設計內容。區塊間可以隨意上下移動,而且可透過螢幕右方的設定介面進行整個區塊的文字大小、首字放大、背景色彩與文字色彩等修正,甚至可以單獨撰寫 CSS 來做設計。因此 WordPress 又稱此編輯器為區塊編輯器。

不過我發現許多功能受到極大限制,不像以往安裝 TinyMCEAdvanced 外掛後可以針對選取字串設定文字大小、顏色,甚至還能建立表格表單。希望以後可以增加相對應的內容設計方式。

根據實際使用過該外掛的用戶而言,評價似乎不高,1648個評價中竟然有高達 943 個一星分數。

其實我也給了這套官方的外掛插件(Plugins)相當低的分數,最讓我討厭的主要有兩點,其一是這種視覺化編輯器有點佔用系統資源,大量書寫與其他應用時會出現延遲感,例如我在表格中每點選一個格子,可能得誇張到延遲 5 秒才能繼續動作,我現在的筆記型電腦的風扇正在狂飆呢;其二則是整體視覺看起來雖然漂亮,但是我們作者的編輯體驗卻是被破壞了。

以下圖為例,我在編輯第二段的時候,Gutenberg的特點之一的區塊編輯會自動跳出遮蔽上一段結尾的文字效果選擇,這在實際書寫體驗中會造成思考連貫性的斷開。

Gutenberg

WordPress 5.0 糟糕的編輯體驗

實際上我們並不需要時時刻刻都會修改文字效果,更多的情況是我們會隨時重新整理文字的順序,但是這在新的編輯器中並沒有過去單純文字編輯來得方便。

WP 也想到了這個問題,因此在編輯區域右上角的功能表中,點選「Top Toolbar」功能選項,就能將這些礙眼的文字效果移到螢幕最上方。

不過即便如此,新版的視覺化編輯器仍有許多罄竹難書的問題,實在讓人無法喜愛。例如過去固定網誌(Premalink)可以自行修改,但是現在發表文章前卻無法變更,直到發表後才能再更改網址(開什麼玩笑)。

上面的問題應該是 Bug 臭蟲造成的,在我其他網站上沒有這個問題,就算在這個網站的頁面(Page)上也沒這個問題,單單只發生在文章(Post)發表。但是這也證明新編輯器的問題很大。

幸好,WordPress 也怕強硬改變會造成使用者的反感,因此推出傳統編輯器的外掛插件「Classic Editor」,有需要的朋友可以到外掛中尋找,再搭配 TinyMCEAdvanced 這套編輯器外掛(支援文字選取色彩與表格設置)才是我目前最理想的文字編輯模式。

但是 WP 開發單位也已經公開表示,這個傳統編輯器外掛只會更新到 2021 年為止,大家還是需要有個心理準備。

另外提醒大家,你在安裝傳統編輯器外掛後,不要直接用「傳統編輯器」編輯先前已經使用「視覺化編輯器(區塊編輯器)」發表的文章,否則程式碼會變得很難看。這時候要先用「區塊編輯器」進入編輯畫面後,找到編輯器的功能區塊,點擊「切換至傳統編輯器」選項,這樣系統才會自動轉換兩套不同的編輯內容。

有趣的是,這次 WordPress 強制採用新設計,把舊設計拉出來獨立成一個外掛的作法。意外讓舊設計的外掛獲得一面倒的好評。我都直接給五顆星,還評語說從未見過如此好的程式(壞笑)。其實新設計以前也是用外掛方式讓人下載,結果獲得超差的評語。團隊乾脆強制大家用。只能佩服他們真心永不放棄。

最後提醒大家,如果在更新 WordPress 5.0 後發表文章時,發現螢幕上一直跳出「Updating failed」的錯誤警告,可能是你的防火牆正在發揮作用。試著將 Gutenberg 視覺化編輯器從你的防火牆限制名單中排除,應該就能解決這個問題了。

發表意見